春种秋收指标 通达信公式(图解)通达信公式

2019-08-27    来源:拾荒网    编辑:胖企鹅    浏览量:
春种秋收指标

 

春种秋收指标 通达信公式(图解),拾荒网

 

N:=6;M:=30;LH:=80;P:=27;

VAR1:=HHV(HIGH,9)-LLV(LOW,9);

VAR2:=HHV(HIGH,9)-CLOSE;

VAR3:=CLOSE-LLV(LOW,9);

VAR4:=VAR2/VAR1*100-70;

VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

VAR6:=(2*CLOSE+HIGH+LOW)/4;

VAR7:=SMA(VAR3/VAR1*100,3,1);

VAR8:=LLV(LOW,34);

VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);

VARA:=IF(VAR9>100,VAR9-100,0);

VARB:=HHV(HIGH,34);

VARC:=EMA((VAR6-VAR8)/(VARB-VAR8)*100,8);

VARD:=EMA(VARC,5);

★开仓进宝: STICKLINE(VARC> 17 AND VARC< 59 AND VARC-VARD>= 0,1,10,3,0),COLORYELLOW;{45.28%}

★守仓待涨: STICKLINE(VARC> 47 AND VARC< 70 AND VARC-VARD>= 0,42,50,3,0),COLORLIMAGENTA;

丰收在望: STICKLINE(VARC> 70 AND VARC-VARD>= 0,77,82,3,0),COLORMAGENTA;

无限风光: STICKLINE(VARC-VARD> 0,VARC,VARD,3,0),COLORRED;

★乌云翻滚: STICKLINE(VARC> 65 AND VARC< 80 AND VARC-VARD< 0,75,85,3,0),COLORLIGREEN;

泰坦尼克: STICKLINE(VARC-VARD< 0,VARC,VARD,3,1),COLORGREEN;

冰山沉船: STICKLINE(VARC> 26 AND VARC< 65 AND VARC-VARD< 0,70,65,3,0),COLORCYAN;

青龙戏水: STICKLINE(VARC> 5 AND VARC< 35 AND VARC-VARD< 0,18,20,3,0),COLORLIGREEN;{46.56%}

VARE:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;

VARF:=SMA(VARE,9,1)+100;

VAR10:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

VAR11:=SMA(VAR10,3,1);

VAR12:=SMA(VAR11,3,1)+100;

VAR13:=VAR12-VARF;

逃顶: IF(VAR13> 100,VAR13-100,0);

★空仓观望★: STICKLINE(CLOSE< EMA(CLOSE,P),-15,-3,3,0),COLORLICYAN;

VAR14:=ZIG(3,13);

乌云盖顶: STICKLINE(REF(VAR14,2)< REF(VAR14,1) AND VAR14< REF(VAR14,1),95,55,3,0),COLORBLUE;

猎豹出击: STICKLINE(REF(VAR14,2)> REF(VAR14,1) AND VAR14> REF(VAR14,1),10,45,3,0),COLORLIRED;

DRAWICON(CROSS(VARD,16),20,3);

DRAWTEXT(CROSS(VARD,16),VARD+12,'★春种'),COLORLIRED;{48.41}

DRAWICON(CROSS(VARD,VARC) AND VARD> 74,VARD-5,1);{51.56%/+1.64%/5385}

DRAWTEXT(CROSS(VARD,VARC) AND VARD> 74,VARD-20,'★丰收'),COLORYELLOW;

 

1
3