逃顶自编指标 通达信公式(图解)通达信公式

2019-08-27    来源:拾荒网    编辑:胖企鹅    浏览量:
逃顶自编指标

逃顶自编指标 通达信公式(图解),拾荒网

 

N1:=14;N2:=34;N3:=55;N4:=5;

MA1:MA(CLOSE,5);

MA2:MA(CLOSE,10);

MA3:MA(CLOSE,20);

MA4:MA(CLOSE,30);

MA5:MA(CLOSE,55);

MA8:MA(CLOSE,125);

MA6:=MA(VOL,5);

MA7:=MA(VOL,40);

VAR1:=EMA(AMOUNT/VOL/100,3);

天际:=EMA(VAR1,240);

水平面:= EMA(VAR1,88)*0.85;

海底:=EMA(VAR1,88)*0.74;

VAR22:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

VAR33:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;

VARF:=(HIGH+LOW+CLOSE)/3;

VAR10:=(VARF-MA(VARF,14))/(0.015*AVEDEV(VARF,14));

VAR11:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;

VAR12:=SMA(VAR11,3,1);

VAR13:=SMA(VAR12,3,1);

VAR14:=3*VAR12-2*VAR13;

VAR15:=CLOSE< REF(CLOSE,1);

VAR16:=OPEN< REF(CLOSE,1);

VAR17:=(VAR13< 10 AND VAR33< -30 AND VAR22>6 AND VAR10<-107);

Q:= VAR17 OR COUNT(VAR17,10) AND VAR15 OR COUNT(VAR17,10) AND VAR16;

AA:=FILTER(Q,20);

RSV:= (CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;

FASTK:=SMA(RSV,3,1);

K:=SMA(FASTK,3,1);

D:=SMA(K,5,1);

A1:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;

A2:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;

WR1:= -100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34));

WR2:= -100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55));

WR3:= -100*(HHV(HIGH,89)-CLOSE)/(HHV(HIGH,89)-LLV(LOW,89));

B:=SMA((3*H+2*C+O+L)/7,10,1);

W1:=-100*(HHV(HHV(B,1),N1)-B)/(HHV(HHV(B,1),N1)-LLV(LLV(B,1),N1));

W2:=-100*(HHV(HHV(B,1),N2)-B)/(HHV(HHV(B,1),N2)-LLV(LLV(B,1),N2));

W3:=-100*(HHV(HHV(B,1),N3)-B)/(HHV(HHV(B,1),N3)-LLV(LLV(B,1),N3));

W4:=-100*(HHV(HHV(B,1),N4)-B)/(HHV(HHV(B,1),N4)-LLV(LLV(B,1),N4));

价格:=(W1+W2+W3+W4)/4;

A:=SMA(VOL,10,1);

WRA1:=-100*(HHV(HHV(A,1),N1)-A)/(HHV(HHV(A,1),N1)-LLV(LLV(A,1),N1));

WRA2:=-100*(HHV(HHV(A,1),N2)-A)/(HHV(HHV(A,1),N2)-LLV(LLV(A,1),N2));

WRA3:=-100*(HHV(HHV(A,1),N3)-A)/(HHV(HHV(A,1),N3)-LLV(LLV(A,1),N3));

WRA4:=-100*(HHV(HHV(A,1),N4)-A)/(HHV(HHV(A,1),N4)-LLV(LLV(A,1),N4));

量:=(WRA1+WRA2+WRA3+WRA4)/4;

WR:=-100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55));

关注买:= CROSS(WR,-45) AND CLOSE>MA5 AND MA3>REF(MA3,1) AND K>REF(K,1);{43.99%/-2.01%/4552}

DRAWTEXT(关注买 ,LOW-LOW*0.02,'▲关注买'),COLORRED;

量价齐升:=((CROSS(量,-45)) OR (CROSS(量,-50))) AND ((CROSS(WR,-45)) OR (CROSS(WR,-50))) AND CROSS(CLOSE,MA4) AND CROSS(CLOSE,MA5);

DRAWTEXT(量价齐升,LOW-LOW*0.02,'▲量价齐升'),COLORYELLOW;

BB:=CLOSE=HIGH AND CLOSE>REF(HIGH,1) AND WR>=REF(WR,1) AND ((REF(CLOSE,1)< EMA(VAR1,88)*0.74) OR( CLOSE< EMA(VAR1,88)*0.74)) AND K< 20 ;

半仓买:=FILTER(BB,5);{50.19%/+0.66%/516}

DRAWICON(半仓买,LOW-LOW*0.01,1),COLORRED;

DRAWTEXT(半仓买,LOW-LOW*0.01,'半仓买'),COLORRED;

M:= WR1=WR2 AND WR1=WR3 ;

VAR2:=VOL*CLOSE;

VAR3:=EMA(VAR2,11)/EMA(VOL,11);

VAR4:=(EMA(CLOSE,5)-VAR3)/VAR3*100;

VAR5:=EMA(VAR4,5);

卖出:= CROSS(VAR5,VAR4) AND VAR5>2;

DRAWTEXT(卖出,HIGH*1.03,'▼卖出'),COLORGREEN;

D1:= CROSS(VAR4,VAR5) AND VAR5< -2 AND VAR3>REF(VAR3,1) AND (LOW< 海底 OR CLOSE< 海底) AND K< 20 AND K>REF(K,1) AND LOW< COST(1) AND CLOSE>(COST(1)) AND CLOSE>REF(HIGH,1);

D2:=(( CLOSE< 海底)OR(LOW < 海底)) AND CLOSE>LOW AND K< 20 AND K>REF(K,1) AND LOW< (COST(1)) AND CLOSE>(COST(1)) AND M AND CLOSE>REF(HIGH,1);

D3:= CROSS(VAR4,VAR5) AND VAR5< -6.3 AND CLOSE>REF(HIGH,1) AND (LOW< 海底 OR CLOSE< 海底) AND K< 20 AND K>REF(K,1) AND LOW< COST(0.5) AND CLOSE>(COST(1));

D4:=AA;

全仓买:=D1 OR D2 OR D3 OR D4;{51.75%/0.07%/74}

DRAWICON(全仓买,LOW-LOW*0.1,1),COLORYELLOW;

DRAWTEXT(全仓买,LOW-LOW*0.09,'全仓买'),COLORYELLOW;

卖:=CLOSE>REF(CLOSE,1)AND WR/1.5< REF(WR,1);

DRAWTEXT(卖,HIGH*1.03,'▼绝顶2'),COLORGREEN;

绝顶:=WR=0 AND 量=0 AND 价格>-10;

DRAWTEXT(绝顶,HIGH*1.03,'▼绝顶1'),COLORGREEN;

VAR7:=REF(CLOSE,1);

VAR8:=SMA(MAX(CLOSE-VAR7,0),7,1)/SMA(ABS(CLOSE-VAR7),7,1)*100;

VAR9:=CROSS(69,VAR8);

VARA:=FILTER(VAR9,4);

DRAWICON(VARA,HIGH*1.035,2);

DRAWTEXT(VARA,HIGH*1.04,'绝卖出'),COLORCYAN;

1
3