龙蛇鼠指标 通达信公式(图解)通达信公式

2019-08-27    来源:拾荒网    编辑:胖企鹅    浏览量:
龙蛇鼠指标

龙蛇鼠指标 通达信公式(图解),拾荒网

T:=20;

S1:=STD(C,30);

ZF:=(S1-REF(S1,1))/S1;

A:=INTPART(T*(1+ZF));

B:=MIN(T,60);

M:=MAX(T,20);

MID:MA(C,T);

X:=STD(C,T);

UP:MID + 2*X,COLOR00A600;

DN:MID - 2*X,COLOR5E5EFF;

MA30:= MA(CLOSE,30);

通道上轨:MA30 + 2*STD(CLOSE,65),COLOR489100,LINETHICK3 ;

通道下轨:MA30 - 2*STD(CLOSE,60),COLOR5200CC,LINETHICK3;

VAR1:=MA(CLOSE,5);

VAR2:=MA(CLOSE,34);

VAR3:=MA(CLOSE,60);

VARA:=REF(CLOSE,1);

VARE:=SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100;

DRAWTEXT( CROSS(84,VARE) OR ( CROSS(84,VARE) AND UP>通道上轨) ,HIGH,'见好就收'),colorgreen;

VARF:=(2*CLOSE+HIGH+LOW)/4;

VAR4:=LLV(LOW,34);

VAR5:=HHV(HIGH,34);

VAR6:=EMA((VARF-VAR4)/(VAR5-VAR4)*100,6);

VAR7:=EMA(0.667*REF(VAR6,1)+0.333*VAR6,4);

DRAWTEXT(IF(COUNT(CLOSE< REF(CLOSE,1),8)/8>0.3 AND COUNT(VAR6>VAR7,3) AND REF(LOW,1)=LLV(LOW,120) AND

CLOSE>OPEN,1,0),LOW,'★出击'),coloryellow;{55.17%/+2.58%/2929}

仙人指:(C*2+H+L)/4,COLOR0000FF ;

KK3:=C>MID AND REF(SUM(C< MID,2)=2,2) AND SUM(CROSS(C,MID),2)>0;

VAR1A:=LLV(LOW,21);

VAR2A:=HHV(HIGH,21);

快1:=EMA((CLOSE-VAR1A)/(VAR2A-VAR1A)*100,5);

VAR3A:=EMA((CLOSE-VAR1A)/(VAR2A-VAR1A)*50,13);

VAR4A:=EMA(0.667*REF(快1,1)+0.333*快1,2);

VAR5A:=LLV(LOW,55);

VAR6A:=HHV(HIGH,34);

VAR7A:=EMA((CLOSE-VAR5A)/(VAR6A-VAR5A)*100,3);

VAR8A:=(VAR3A+VAR7A)/2;

VAR9A:=EMA(0.667*REF(VAR7A,1)+0.333*快1,2);

VARAA:=EMA(VAR8A,5);

VARB:=EMA(0.667*REF(VARAA,1)+0.333*VARAA,2);

快2:=MA(快1,5);

DRAWICON(CROSS(快1,VAR3A),LOW,1);

DRAWTEXT(CROSS(快1,VARB) AND VARB< 30,LOW,'低点'),COLOR0073FF;{49%}

X1:=(C+L+H)/3;

X2:=EMA(X1,6);

X3:=EMA(X2,5);

VARB1:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*100;

VARB2:=SMA(VARB1,3,1);

V3:=SMA(VARB2,3,1)*VARB1;

V4:=SMA(V3,3,1);

K1:=CROSS(V3,V4);

KK2:=K1 AND SUM(K1,BARSLAST(CROSS(X3,X2)))=1;

VAR1D:=EMA(CLOSE,2)-EMA(CLOSE,89);

VAR1E:=EMA(VAR1D,30);

VAR1F:=2*(VAR1D-VAR1E)*10;

VAR20:=POW(VAR1F,3)*0.1+POW(VAR1F,2);

VAR25:=IF(YEAR< 2058 AND VAR1F>0.015,VAR20,0)/45/4;

JJ :=(C*2+H+L)/4;

SKK :=( EMA(JJ,13) - EMA(JJ,21))*180;

SDD :=EMA(SKK,2);

多方:= (SKK-SDD)*0.000000001;

空方:= -1*(SKK-SDD)*0.000000001;

KK1:=CROSS(多方,空方);

M1:=1;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

KA1:=V>=MA(V,5) AND C>=REF(C,1) AND CROSS(K,D) AND K<=30;

KA2:=MAX(DIFF,MAX(DEA,MACD))<=0;

KK4:=IF(M1=1,KA1 AND KA2,KA1),LINETHICK0;

KK5:=KK1+KK2+KK3+KK4=4,LINETHICK0,COLORFF00FF;

KK6:=KK1+KK2+KK3=3,LINETHICK0,coloryellow;

KK7:=KK1+KK3+KK4=3,LINETHICK0,colorwhite;

DRAWTEXT(KK5,L*0.99,'龙出'),COLORFF00FF;{0}

DRAWTEXT(KK6 AND KK5< 1,L*0.99,'蛇出'),coloryellow;{0}

DRAWTEXT(KK7 AND KK5< 1,L*0.99,'鼠出'),colorwhite;{0}

1
3